The Second Order Effect

RHEL5 / CentOS5 RPMs for Python 2.5 and 2.6

by on Nov.18, 2009, under Tech Articles, Uncategorized

EDIT : Newer Instructions are here.

this is a repost from my old site.

I’ve created RPMs for RHEL 5.0, hair 5.1, physiotherapy 5.2 and 5.3, men’s health as well as CentOS 5.0, 5.1 and 5.2 for Python 2.5 and 2.6.

The RHEL/CentOS line only supports Python 2.4, and as it’s an integral part of yum and many other packages, any installation of new Pythons will require parallel installation.

(Note : Currently, the 2.5 and 2.6 RPMs cannot both be installed without an RPM –force)

TODO : Repository URL & GPG signing

As for the RPMs themselves :



Neither of these packages fully pass the Python test suite (import test.autotest).

That being said, we’ve been using the Python 2.5 package, released by Bashton, in production for a while now, and we haven’t seen any problems.

4 tests failed: test_distutils test_email test_email_renamed test_nis

I don’t know about email, but there are patches for CentOS/Fedora against distutils, so I expect that’s why it fails the test.

For Python 2.6, note the following :

  • I had to gimp autoconf’s version detection to force it to use 2.59. This may have unintended consequences
  • This RPM uses patches from the Fedora Core 11 Alpha release. (python-2.6-4.fc11 specifically). As Fedora updates this package, I’ll release updates. (Feel free to email to remind.)


Just install the RPMs for the version that you want. You’ll need at least the base python version package and the libs package.
To start Python 2.6, type python26 at your commandline rather than python. (Your original Python 2.4 is still installed.)
If you’re installing packages with setuptools, make sure to use the correct python version. (i.e. python26 install)
If you’d like to build an x86_64, call rpmbuild –rebuild with the appropriate arch setting.


10 Comments for this entry

  • ornicum

    Hi! I have a problem with installation python-2.6 on CentOS. It’s need libs and when I try to install libs I see this:
    [root@~]# rpm -ihv python26-libs-2.6-geekymedia1.i386.rpm
    error: Failed dependencies:
    python26 = 2.6-geekymedia1 is needed by python26-libs-2.6-geekymedia1.i386
    What can I do to fix it?
    Best regards, ornicum.

  • Rizwan Kassim


    install both the python26libs and python26 at the same time.

  • Sharath

    Hi First I dont know about the errors that i have to install all the required packages along with the python 2.6 installation(RHEL5). So I installed it. Now what should I do. Do i need uninstall?? and install your RPM’s? How to do uninstall (am new to RPM world) and what ORDER do I need follow for above packages for your rpm installation simply “rpm -ivh” dows that would be enough. Thanks in advance

  • guy_need_x64_python

    Is there a x64 version available ?

  • Jonathan

    Thanks for packaging python 2.6 for EL5.

    It would be nice if you would consider managing these pacakges in EPEL (

    It would make distribution and installation somewhat easier as well as you reaching a bigger audience.

    Kind regards,


  • MS

    Where can I find the CentOS rpm for python 2.6.5 and equivalent python-devel for 64 bit hosts?

  • Luca

    I try to install the packages on Centos 5.2, but I obtein the following error:

    [root@localhost python2.6]# rpm -Uvh python26-* tkinter26-2.6-geekymedia1.i386.rpm
    error: Failed dependencies: is needed by tkinter26-2.6-geekymedia1.i386

    I try to search the libTix8.4.20 for my Centos with no results-


  • reseph

    From what I can tell, this is a UCS4 build? It creates many incompatibilities namely this:

    Can you confirm this is a UCS4 build?

  • Inderpreet Singh

    Hi Luca,

    To fi those dependencies, just do:
    yum install tix tcl tk

    And then the dependencies will be all set for tkinter by geekymedia.


  • mthbyd

    when I try to install your package on a RHEL 5

    rpm -ivh python25-2.5.1-bashton1.i386.rpm
    error: Failed dependencies: is needed by python25-2.5.1-bashton1.i386

    Where I can find this lib ?

    Thank you

1 Trackback or Pingback for this entry

  • Installing Orbited on CentOS 5 - ToxicComa

    [...] The first step is to install Python 2.5. Sadly, we can’t simply update the Python 2.4 that comes stock with CentOS 5 as it is required for yum to work properly. To get around this we will be installing a parallel version of Python 2.5. This part of the setup is using the parallel install of Python as described and created by [...]

Leave a Reply

Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!

Visit our friends!

A few highly recommended friends...